Code

Added simple support to configure and run multiple instances of collectd to
[collectd.git] / collectd.spec
1 Summary:        Statistics collection daemon for filling RRD files.
2 Name:           collectd
3 Version:        3.7.2
4 Release:        1
5 Source:         http://verplant.org/collectd/%{name}-%{version}.tar.gz
6 License:        GPL
7 Group:          System Environment/Daemons
8 BuildRoot:      %{_tmppath}/%{name}-%{version}-root
9 BuildPrereq:    lm_sensors-devel, mysqlclient10-devel | mysql-devel, rrdtool-devel
10 Requires:       rrdtool
11 Packager:       Florian octo Forster <octo@verplant.org>
12 Vendor:         Florian octo Forster <octo@verplant.org>
14 %description
15 collectd is a small daemon written in C for performance.  It reads various
16 system  statistics  and updates  RRD files,  creating  them if neccessary.
17 Since the daemon doesn't need to startup every time it wants to update the
18 files it's very fast and easy on the system. Also, the statistics are very
19 fine grained since the files are updated every 10 seconds.
21 %package mysql
22 Summary:        mysql-module for collectd.
23 Group:          System Environment/Daemons
24 Requires:       collectd = %{version}, mysqlclient10 | mysql
25 %description mysql
26 MySQL  querying  plugin.  This plugins  provides data of  issued commands,
27 called handlers and database traffic.
29 %package sensors
30 Summary:        libsensors-module for collectd.
31 Group:          System Environment/Daemons
32 Requires:       collectd = %{version}, lm_sensors
33 %description sensors
34 This  plugin  for  collectd  provides  querying  of sensors  supported  by
35 lm_sensors.
37 %prep
38 rm -rf $RPM_BUILD_ROOT
39 %setup
41 %build
42 ./configure --prefix=%{_prefix} --sbindir=%{_sbindir} --mandir=%{_mandir} --libdir=%{_libdir}
43 make
45 %install
46 make install DESTDIR=$RPM_BUILD_ROOT
47 mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
48 cp contrib/collectd.conf $RPM_BUILD_ROOT/etc/collectd.conf
49 cp contrib/init.d-rh7 $RPM_BUILD_ROOT/etc/rc.d/init.d/collectd
50 mkdir -p $RPM_BUILD_ROOT/var/lib/collectd
51 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.a
52 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
54 %clean
55 rm -rf $RPM_BUILD_ROOT
57 %files
58 %defattr(-,root,root)
59 %doc AUTHORS COPYING ChangeLog INSTALL NEWS README
60 %doc contrib
61 %config /etc/collectd.conf
62 %attr(0755,root,root) /etc/rc.d/init.d/collectd
63 %attr(0755,root,root) %{_sbindir}/collectd
64 %attr(0444,root,root) %{_mandir}/man1/*
65 %attr(0444,root,root) %{_mandir}/man5/*
66 %attr(0444,root,root) %{_libdir}/%{name}/battery.so*
67 %attr(0444,root,root) %{_libdir}/%{name}/cpu.so*
68 %attr(0444,root,root) %{_libdir}/%{name}/cpufreq.so*
69 %attr(0444,root,root) %{_libdir}/%{name}/df.so*
70 %attr(0444,root,root) %{_libdir}/%{name}/disk.so*
71 %attr(0444,root,root) %{_libdir}/%{name}/hddtemp.so*
72 %attr(0444,root,root) %{_libdir}/%{name}/load.so*
73 %attr(0444,root,root) %{_libdir}/%{name}/memory.so*
74 %attr(0444,root,root) %{_libdir}/%{name}/nfs.so*
75 %attr(0444,root,root) %{_libdir}/%{name}/ping.so*
76 %attr(0444,root,root) %{_libdir}/%{name}/processes.so*
77 %attr(0444,root,root) %{_libdir}/%{name}/serial.so*
78 %attr(0444,root,root) %{_libdir}/%{name}/swap.so*
79 %attr(0444,root,root) %{_libdir}/%{name}/tape.so*
80 %attr(0444,root,root) %{_libdir}/%{name}/traffic.so*
81 %attr(0444,root,root) %{_libdir}/%{name}/users.so*
82 %dir /var/lib/collectd
84 %files mysql
85 %attr(0444,root,root) %{_libdir}/%{name}/mysql.so*
87 %files sensors
88 %attr(0444,root,root) %{_libdir}/%{name}/sensors.so*
90 %changelog
91 * Sat Feb 18 2006 Florian octo Forster <octo@verplant.org> 3.7.2-1
92 - Include `tape.so' so the build doesn't terminate because of missing files..
93 - New upstream version
95 * Sat Feb 04 2006 Florian octo Forster <octo@verplant.org> 3.7.1-1
96 - New upstream version
98 * Mon Jan 30 2006 Florian octo Forster <octo@verplant.org> 3.7.0-1
99 - New upstream version
100 - Removed the extra `hddtemp' package
102 * Tue Jan 24 2006 Florian octo Forster <octo@verplant.org> 3.6.2-1
103 - New upstream version
105 * Fri Jan 20 2006 Florian octo Forster <octo@verplant.org> 3.6.1-1
106 - New upstream version
108 * Fri Jan 20 2006 Florian octo Forster <octo@verplant.org> 3.6.0-1
109 - New upstream version
110 - Added config file, `collectd.conf(5)', `df.so'
111 - Added package `collectd-mysql', dependency on `mysqlclient10 | mysql'
113 * Wed Dec 07 2005 Florian octo Forster <octo@verplant.org> 3.5.0-1
114 - New upstream version
116 * Sat Nov 26 2005 Florian octo Forster <octo@verplant.org> 3.4.0-1
117 - New upstream version
119 * Sat Nov 05 2005 Florian octo Forster <octo@verplant.org> 3.3.0-1
120 - New upstream version
122 * Tue Oct 26 2005 Florian octo Forster <octo@verplant.org> 3.2.0-1
123 - New upstream version
124 - Added statement to remove the `*.la' files. This fixes a problem when
125   `Unpackaged files terminate build' is in effect.
126 - Added `processes.so*' to the main package
128 * Fri Oct 14 2005 Florian octo Forster <octo@verplant.org> 3.1.0-1
129 - New upstream version
130 - Added package `collectd-hddtemp'
132 * Fri Sep 30 2005 Florian octo Forster <octo@verplant.org> 3.0.0-1
133 - New upstream version
134 - Split the package into `collectd' and `collectd-sensors'
136 * Fri Sep 16 2005 Florian octo Forster <octo@verplant.org> 2.1.0-1
137 - New upstream version
139 * Mon Sep 10 2005 Florian octo Forster <octo@verplant.org> 2.0.0-1
140 - New upstream version
142 * Mon Aug 29 2005 Florian octo Forster <octo@verplant.org> 1.8.0-1
143 - New upstream version
145 * Sun Aug 25 2005 Florian octo Forster <octo@verplant.org> 1.7.0-1
146 - New upstream version
148 * Sun Aug 21 2005 Florian octo Forster <octo@verplant.org> 1.6.0-1
149 - New upstream version
151 * Sun Jul 17 2005 Florian octo Forster <octo@verplant.org> 1.5.1-1
152 - New upstream version
154 * Sun Jul 17 2005 Florian octo Forster <octo@verplant.org> 1.5-1
155 - New upstream version
157 * Mon Jul 11 2005 Florian octo Forster <octo@verplant.org> 1.4.2-1
158 - New upstream version
160 * Sat Jul 09 2005 Florian octo Forster <octo@verplant.org> 1.4-1
161 - Built on RedHat 7.3