Code

added conditions and implemented AC_COLLECTD() macro.
[collectd.git] / collectd.spec
1 Summary:        Statistics collection daemon for filling RRD files.
2 Name:           collectd
3 Version:        3.5.0
4 Release:        1
5 Source:         http://verplant.org/collectd/%{name}-%{version}.tar.gz
6 License:        GPL
7 Group:          System Environment/Daemons
8 BuildRoot:      %{_tmppath}/%{name}-%{version}-root
9 BuildPrereq:    lm_sensors-devel, rrdtool-devel
10 Requires:       rrdtool
11 Packager:       Florian octo Forster <octo@verplant.org>
12 Vendor:         Florian octo Forster <octo@verplant.org>
14 %description
15 collectd is a small daemon written in C for performance.  It reads various
16 system  statistics  and updates  RRD files,  creating  them if neccessary.
17 Since the daemon doesn't need to startup every time it wants to update the
18 files it's very fast and easy on the system. Also, the statistics are very
19 fine grained since the files are updated every 10 seconds.
21 %package sensors
22 Summary:        libsensors-module for collectd.
23 Group:          System Environment/Daemons
24 Requires:       collectd = %{version}, lm_sensors
25 %description sensors
26 This  plugin  for  collectd  provides  querying  of sensors  supported  by
27 lm_sensors.
29 %package hddtemp
30 Summary:        hddtemp-module for collectd.
31 Group:          System Environment/Daemons
32 Requires:       collectd = %{version}, hddtemp >= 0.3
33 %description hddtemp
34 This plugin for  collectd provides querying  the hddtemp-daemon.  For more
35 information see hddtemp's homepage:  http://www.guzu.net/linux/hddtemp.php
37 %prep
38 rm -rf $RPM_BUILD_ROOT
39 %setup
41 %build
42 ./configure --prefix=%{_prefix} --sbindir=%{_sbindir} --mandir=%{_mandir} --libdir=%{_libdir}
43 make
45 %install
46 make install DESTDIR=$RPM_BUILD_ROOT
47 mkdir -p $RPM_BUILD_ROOT/etc/default
48 cp debian/collectd.default $RPM_BUILD_ROOT/etc/default/collectd
49 mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
50 cp contrib/init.d-rh7 $RPM_BUILD_ROOT/etc/rc.d/init.d/collectd
51 mkdir -p $RPM_BUILD_ROOT/var/lib/collectd
52 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.a
53 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
55 %clean
56 rm -rf $RPM_BUILD_ROOT
58 %files
59 %defattr(-,root,root)
60 %doc AUTHORS COPYING ChangeLog INSTALL NEWS README
61 %doc contrib
62 %config /etc/default/collectd
63 %attr(0755,root,root) /etc/rc.d/init.d/collectd
64 %attr(0755,root,root) %{_sbindir}/collectd
65 %attr(0444,root,root) %{_mandir}/man1/*
66 %attr(0444,root,root) %{_libdir}/%{name}/cpu.so*
67 %attr(0444,root,root) %{_libdir}/%{name}/cpufreq.so*
68 %attr(0444,root,root) %{_libdir}/%{name}/disk.so*
69 %attr(0444,root,root) %{_libdir}/%{name}/load.so*
70 %attr(0444,root,root) %{_libdir}/%{name}/memory.so*
71 %attr(0444,root,root) %{_libdir}/%{name}/nfs.so*
72 %attr(0444,root,root) %{_libdir}/%{name}/ping.so*
73 %attr(0444,root,root) %{_libdir}/%{name}/processes.so*
74 %attr(0444,root,root) %{_libdir}/%{name}/serial.so*
75 %attr(0444,root,root) %{_libdir}/%{name}/swap.so*
76 %attr(0444,root,root) %{_libdir}/%{name}/traffic.so*
77 %attr(0444,root,root) %{_libdir}/%{name}/users.so*
78 %dir /var/lib/collectd
80 %files sensors
81 %attr(0444,root,root) %{_libdir}/%{name}/sensors.so*
83 %files hddtemp
84 %attr(0444,root,root) %{_libdir}/%{name}/hddtemp.so*
86 %changelog
87 * Wed Dec 07 2005 Florian octo Forster <octo@verplant.org> 3.5.0-1
88 - New upstream version
90 * Sat Nov 26 2005 Florian octo Forster <octo@verplant.org> 3.4.0-1
91 - New upstream version
93 * Sat Nov 05 2005 Florian octo Forster <octo@verplant.org> 3.3.0-1
94 - New upstream version
96 * Tue Oct 26 2005 Florian octo Forster <octo@verplant.org> 3.2.0-1
97 - New upstream version
98 - Added statement to remove the `*.la' files. This fixes a problem when
99   `Unpackaged files terminate build' is in effect.
100 - Added `processes.so*' to the main package
102 * Fri Oct 14 2005 Florian octo Forster <octo@verplant.org> 3.1.0-1
103 - New upstream version
104 - Added package `collectd-hddtemp'
106 * Fri Sep 30 2005 Florian octo Forster <octo@verplant.org> 3.0.0-1
107 - New upstream version
108 - Split the package into `collectd' and `collectd-sensors'
110 * Fri Sep 16 2005 Florian octo Forster <octo@verplant.org> 2.1.0-1
111 - New upstream version
113 * Mon Sep 10 2005 Florian octo Forster <octo@verplant.org> 2.0.0-1
114 - New upstream version
116 * Mon Aug 29 2005 Florian octo Forster <octo@verplant.org> 1.8.0-1
117 - New upstream version
119 * Sun Aug 25 2005 Florian octo Forster <octo@verplant.org> 1.7.0-1
120 - New upstream version
122 * Sun Aug 21 2005 Florian octo Forster <octo@verplant.org> 1.6.0-1
123 - New upstream version
125 * Sun Jul 17 2005 Florian octo Forster <octo@verplant.org> 1.5.1-1
126 - New upstream version
128 * Sun Jul 17 2005 Florian octo Forster <octo@verplant.org> 1.5-1
129 - New upstream version
131 * Mon Jul 11 2005 Florian octo Forster <octo@verplant.org> 1.4.2-1
132 - New upstream version
134 * Sat Jul 09 2005 Florian octo Forster <octo@verplant.org> 1.4-1
135 - Built on RedHat 7.3