Code

rules: Disable preprocessor warnings on kfreebsd.
[pkg-collectd.git] / debian / rules
index 11ef4ccdd3c3a90e013afef2717b268acb4ba6f4..168bb186b6fd9a14c35ce78417a8fa19e2108e99 100755 (executable)
@@ -30,6 +30,12 @@ CPPFLAGS += -DLT_LAZY_OR_NOW='RTLD_LAZY|RTLD_GLOBAL'
 CPPFLAGS += -UCONFIGFILE
 CPPFLAGS += -DCONFIGFILE='\"/etc/collectd/collectd.conf\"'
 
+# A PostgreSQL header redefines CACHE_LINE_SIZE on FreeBSD.
+# Cf. https://bugs.debian.org/760719 and https://bugs.debian.org/763098
+ifeq (,$(filter kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
+       CPPFLAGS += -Wp,-w
+endif
+
 LDFLAGS = $(shell dpkg-buildflags --get LDFLAGS)
 
 # The archdir map has been copied from openjdk-6's debian/rules.